#1  
Old 28th March 2012, 11:55 PM
Markus Hundt
 
Posts: n/a
Default Gateway in Standard behaves different when started as a service

Hi, we use Portal Standard 3.71.

Today i tried an installation on a Windows 2008 Server.

PortalGateway.html is a customized version, showing correctly when
gateway is started as an application. With the same configuration
started as a service obviously another (internal) html is used, showing
some rudimental kind of Nexus advertisement:

"Portal Gateway is now ready to be used."

"Portal Host and Viewer can be downloaded from
http://www.nexusdb.com/portal/"

Is this a leftover from trial versions?

Or is it WAD? I don't hope so...

Greetings
Markus




  #2  
Old 29th March 2012, 08:30 AM
Eivind Bakkestuen [NDD]
 
Posts: n/a
Default Re: Gateway in Standard behaves different when started as a service

> Is this a leftover from trial versions?

Looking at the source, there's a good chance that your html file is not
in the directory the service expects.

--
Eivind Bakkestuen [NDD]
  #3  
Old 29th March 2012, 05:45 PM
Markus Hundt
 
Posts: n/a
Default Re: Gateway in Standard behaves different when started as a service

Am 28.03.2012 23:30, schrieb Eivind Bakkestuen [NDD]:
>
> Looking at the source, there's a good chance that your html file is not
> in the directory the service expects.
>

Actually in same directory as the .exe-file

  #4  
Old 29th March 2012, 06:11 PM
Markus Hundt
 
Posts: n/a
Default Re: Gateway in Standard behaves different when started as a service

Am 28.03.2012 23:30, schrieb Eivind Bakkestuen [NDD]:
>
> Looking at the source, there's a good chance that your html file is not
> in the directory the service expects.
>

Got it (ProgramData - directory)

Thx for the advice.

Perhaps this and other stuff like it should find it's way into Portal's
manual? (Could not resist )



Greetings
Markus
  #5  
Old 29th March 2012, 07:36 PM
Markus Hundt
 
Posts: n/a
Default Re: Gateway in Standard behaves different when started as a service

Am 28.03.2012 23:30, schrieb Eivind Bakkestuen [NDD]:
>
> Looking at the source, there's a good chance that your html file is not
> in the directory the service expects.
>

I can hardly believe it - Portal Gateway as a service expects the
PortalGateway.html in <drive>\windows\system32

good old procmon.exe told me...

WAD?




  #6  
Old 29th March 2012, 09:19 PM
Eivind Bakkestuen [NDD]
 
Posts: n/a
Default Re: Gateway in Standard behaves different when started as a service

> > Looking at the source, there's a good chance that your html file is
> > not in the directory the service expects.
> >

> I can hardly believe it - Portal Gateway as a service expects the
> PortalGateway.html in <drive>\windows\system32


Again, looking at the source, the file is loaded from whatever the
"current directory" is. Apparently, this is usually the system
directory when running as a service. It is something that I'll add to
the todo list to have a look at.

--
Eivind Bakkestuen [NDD]
  #7  
Old 30th March 2012, 07:52 AM
Jim Allison
 
Posts: n/a
Default Re: Gateway in Standard behaves different when started as a service

"Eivind Bakkestuen [NDD]" <Ieivind.bakkestuenHATE@nexusdb.comSPAM> wrote in
news:xn0hw6hiv164m8r000@news.nexusdb.com:

>> > Looking at the source, there's a good chance that your html file is
>> > not in the directory the service expects.
>> >

>> I can hardly believe it - Portal Gateway as a service expects the
>> PortalGateway.html in <drive>\windows\system32

>
> Again, looking at the source, the file is loaded from whatever the
> "current directory" is. Apparently, this is usually the system
> directory when running as a service. It is something that I'll add to
> the todo list to have a look at.


I had added this to the tracker a while back:
http://www.nexusdb.com/mantis/view.php?id=1141

I've added these notes to it.

Thanks,
--
Jim Allison
Development Support, SpeedLine Solutions, Inc.
Tel: 1-888-400-9185 ext. 2214 | Fax: 1-866-850-9688
www.speedlinesolutions.com


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gateway service name Hannes Danzl[NDD] nexusdb.public.support.portal 10 6th February 2010 01:24 PM
Standard SQL Field Types Scott Martin nexusdb.public.support.sql 2 13th December 2006 07:48 AM
ANN: FREE kbmMW v2.5x Standard Edition! Kim Madsen nexusdb.public.support.thirdparty 0 17th December 2005 10:06 PM
Non-standard server name not returned by broadcast Richard Light nexusdb.public.support 5 3rd July 2005 12:44 AM
NexusDB supports standard SQL/PSM Martijn Tonies nexusdb.public.support 1 30th June 2005 10:29 PM


All times are GMT +11. The time now is 09:19 AM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.