View Single Post
  #15  
Old 17th March 2018, 04:56 AM
Shane Stump
 
Posts: n/a
Default Re: Access violation when link with runtime packages = off

On 3/16/2018 12:54 PM, Shane Stump wrote:
> Howdy!
> On 3/16/2018 7:26 AM, kts wrote:
>> Hi,
>>
>> Thanks for your feedback. It is very interesting that it works for you.
>> Which nexus versions are you running? Are you running as embedded
>> server? We run nexus as embedded server in our application.
>>
>> 1) I did run Rad Studio 10.2.2, and now just installed 10.2.3 with Nexus
>> version 4.1302.

> I am not running 10.2.3 with NexusDB 4.13.02
>
>>
>> 2) It happens when launching the application. I get the following error
>> in a simple test application:
>>
>> First chance exception at $006BBD75. Exception class $C0000005 with
>> message 'access violation at 0x006bbd75: write of address 0x0088c0d4'.
>> Process Project1.exe (9484)

>
> I am having no such issues but I did for once back with version 10.2.2
> and I was briefly forced to link with packages (which I cannot release
> my application with).
>
> I do NOT use embedded NexusDB any longer just the client / server. For
> embedded, I am using SQLITE.
>
> Are you linking pure static? That is, no RTL and no link with Delphi
> RTL? What is your default character (i.e. char or w_char)? Mine is w_char.
>
> Also, have you gone through the NexusDB group project file and made sure
> that ALL c++ files are generated (the default install does NOT).
>
> Hope some of this helps!
>
> Have a great weekend!
>
> Shane


That should have been "now" running with 10.2.3 + NexusDB 4.13.02!