#11  
Old 29th February 2012, 12:19 AM
susoftware susoftware is offline
Junior Member
 
Join Date: Dec 2011
Posts: 7
Default

Quote:
Originally Posted by Rodrigo Gomez [NDX] View Post
I still have problems
debugging (internal exceptions that "bubble up" into the debug session and make it unable
to continue) from time to time.
Same here. Exceptions usually show up as "parameter must not be null. parameter name: source", whatever causes the exception. Debugging is, frankly speaking, a PITA. EF support doesn't work for me at all, neither on the command line, nor using the visual tools.

The current state of the provider is rather usable, but sometimes it has its quirks and problems. What bugs me is the fact that I need to work with this ADO provider and NexusDB to support a legacy application, and the stability is far away from what I get in the Delphi world.

Bugs have been submitted, I'm positive that it'll come along better and better.
  #12  
Old 29th February 2012, 02:14 AM
David Guest
 
Posts: n/a
Default Re: Problem in VS2010

I am using the ADO provider in two web ASP.Net applications and it seems
to be working ok.

However, debugging is a PITA.

I think that NexusDB ought to pay a huge amount of attention to the ADO
provider and the PHP provider. With everything going to the web and the
cloud ... the ADO provider and perhaps the PHP provider will be the only
access to Nexusdb ... and they ought to be as reliable and easy to use
as the NexusDB engine itself.

I also think NexusDB ought to re-examine their pricing structure for ADO
and ODBC and PHP connectors. It seems very inconsistent to allow
unlimited distribution of the server and client/server applications and
then have to pay for installations that use the providers....Its like
dealing with two different development companies....
  #13  
Old 29th February 2012, 06:46 PM
pietera pietera is offline
Junior Member
 
Join Date: Sep 2011
Posts: 4
Default

I am getting this error when i try to connect to Nexus3 Server:

"Database API specific error
The query returned an error (ODBC State: Hy000

Error:
NexusDB:<unnamed TnxODBCWuery instance>:Query preparation failed: Sysntax error at line 369: <builtin_function),<stored_function>,'-','9','*',':','?',<bracketed_binary_string_literal >,<character_string_literal>,...,UNIQUE, UNKNOWN or 'X' expected: Text

[$3CA0/15520]"

It seems to me that the blob fields are the culprits here?

I agree with David Guest that attention should be given to better and/or more reliable connections to NexusDB. At this point in time i have purchased the ODBC driver but dont want to fork out more money for a unreliable ADO provider.

Like i have said earlier we are now forced to use other db systems.

Due to the time it takes to develop WEB applications struggling with database connections adds to the frustrations..

I hope that the vacancy of Hannes does not hamper the development/bug fixing in this department.
  #14  
Old 29th February 2012, 07:32 PM
Eivind Bakkestuen [NDD]
 
Posts: n/a
Default Re: Problem in VS2010

> I am getting this error when i try to connect to Nexus3 Server:

This looks like an ODBC problem, if you can log an issue in our issue
tracker, including what version the ODBC driver is, and what version of
nxServer, we can take a look.



--
Eivind Bakkestuen [NDD]
  #15  
Old 29th February 2012, 08:58 PM
pietera pietera is offline
Junior Member
 
Join Date: Sep 2011
Posts: 4
Default

Issue reported 0001359

Thanks
  #16  
Old 1st March 2012, 12:40 AM
Eivind Bakkestuen [NDD]
 
Posts: n/a
Default Re: Problem in VS2010

> Issue reported 0001359

Thanks

Info about the ODBC driver version you are using is missing.

--
Eivind Bakkestuen [NDD]
  #17  
Old 1st March 2012, 07:42 AM
pietera pietera is offline
Junior Member
 
Join Date: Sep 2011
Posts: 4
Default

Sorry,
It is the latest version nxOdbcDriverV3.10. File date 31/12/2011 02:39PM
There is no file version according to Windows 7?

HTH
  #18  
Old 1st March 2012, 10:55 AM
Eivind Bakkestuen [NDD]
 
Posts: n/a
Default Re: Problem in VS2010

> It is the latest version nxOdbcDriverV3.10. File date 31/12/2011
> 02:39PM


The idea of logging in the issue tracker is to get all the information
needed there; just copying your incomplete newsgroup posting doesn't
help us help you.

You need to give all the steps needed for us to reproduce. What are the
exact steps of reproducing? Run the windows ODBC Data Source
Administrator, enter exactly what SQL statement to test?

When I do the above test with legal SQL, it works for me. We need every
little detail necessary in order to reproduce.

--
Eivind Bakkestuen [NDD]


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't create Data Source VS2010 gorlaz nexusdb.public.support.adoprovider 5 18th March 2011 11:23 AM


All times are GMT +11. The time now is 05:00 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.