Go Back   NexusDB Newsgroups > Support Newsgroups > nexusdb.public.support
Log in
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
  #1  
Old 29th July 2009, 10:32 PM
Wina Jansen
 
Posts: n/a
Default alias created by session not shown in Server configuration V3 and gone after restart

Hello,

I perform a: Dataproxy.nxSession.AddAlias(aAdminName, UNCAdminPathExt) in my
Delphi project.
The alias is added and the programme can connect to it through the server.
If, however, I look into the server (Versie 3.0100 d11, via the internet
explorer), the alias cannot be seen.
When I open the configuration of the server with /interactive the alias can
be seen. No refresh like F5 helps.
It does show the alias when the nxServer is stoppen first, restarted and
configuration is called.

One time I put my machine to restart and after opening the created alias was
gone completely.
Which never happened with V2.

Wina



  #2  
Old 30th July 2009, 08:14 AM
Hannes Danzl[NDD]
 
Posts: n/a
Default Re: alias created by session not shown in Server configuration V3 and gone after restart

Wina Jansen wrote:

> Hello,
>
> I perform a: Dataproxy.nxSession.AddAlias(aAdminName, UNCAdminPathExt) in my
> Delphi project. The alias is added and the programme can connect to it
> through the server. If, however, I look into the server (Versie 3.0100 d11,
> via the internet explorer), the alias cannot be seen. When I open the
> configuration of the server with /interactive the alias can be seen. No
> refresh like F5 helps. It does show the alias when the nxServer is stoppen
> first, restarted and configuration is called.
>
> One time I put my machine to restart and after opening the created alias was
> gone completely. Which never happened with V2.


Actually V2 was buggy. Client side created Aliases should never be stored on
the server. The reason for that is that lots of clients create lots of (temp)
aliases and this would lead to a real mess. That said we do have a feature
request for adding a "Persistent" flag to the AddAlias method that will allow
to create persistent aliases from client side.
  #3  
Old 4th August 2009, 06:29 PM
Wina Jansen
 
Posts: n/a
Default Re: alias created by session not shown in Server configuration V3 and gone after restart

Luckely you put in the aEnforce boolean in the AddAlias.
Without it I won't be able to use V3.

I would plead for keeping it the way it is in V2 (or with the aEnforce in
V3). Isn't it a matter of handling aliases correctly in the programme around
the .addalias statement?

Some of my customers have 30 databases. Every new 'administration' year the
programme makes 30 new databases based on the old ones. It won't sell
anymore to have them put those 30 new aliases by hand in the server first.






"Hannes Danzl[NDD]" <hannes@nexusdb.dbnexus.com> schreef in bericht
news:xn0gd9n946l1weu00b@news.nexusdb.com...
> Wina Jansen wrote:
>
>> Hello,
>>
>> I perform a: Dataproxy.nxSession.AddAlias(aAdminName, UNCAdminPathExt) in
>> my
>> Delphi project. The alias is added and the programme can connect to it
>> through the server. If, however, I look into the server (Versie 3.0100
>> d11,
>> via the internet explorer), the alias cannot be seen. When I open the
>> configuration of the server with /interactive the alias can be seen. No
>> refresh like F5 helps. It does show the alias when the nxServer is
>> stoppen
>> first, restarted and configuration is called.
>>
>> One time I put my machine to restart and after opening the created alias
>> was
>> gone completely. Which never happened with V2.

>
> Actually V2 was buggy. Client side created Aliases should never be stored
> on
> the server. The reason for that is that lots of clients create lots of
> (temp)
> aliases and this would lead to a real mess. That said we do have a feature
> request for adding a "Persistent" flag to the AddAlias method that will
> allow
> to create persistent aliases from client side.



  #4  
Old 4th August 2009, 09:37 PM
Wina Jansen
 
Posts: n/a
Default Re: alias created by session not shown in Server configuration V3 and gone after restart

I am getting a bit confused....
The addalias now also seem to be kept without the aEnforce boolean??
Whereas I have seen my server come up without aliases...


"Wina Jansen" <wj*adfas*com> schreef in bericht
news:4a77e111$1@77-37-8-25....
> Luckely you put in the aEnforce boolean in the AddAlias.
> Without it I won't be able to use V3.
>
> I would plead for keeping it the way it is in V2 (or with the aEnforce in
> V3). Isn't it a matter of handling aliases correctly in the programme
> around the .addalias statement?
>
> Some of my customers have 30 databases. Every new 'administration' year
> the programme makes 30 new databases based on the old ones. It won't sell
> anymore to have them put those 30 new aliases by hand in the server first.
>
>
>
>
>
>
> "Hannes Danzl[NDD]" <hannes@nexusdb.dbnexus.com> schreef in bericht
> news:xn0gd9n946l1weu00b@news.nexusdb.com...
>> Wina Jansen wrote:
>>
>>> Hello,
>>>
>>> I perform a: Dataproxy.nxSession.AddAlias(aAdminName, UNCAdminPathExt)
>>> in my
>>> Delphi project. The alias is added and the programme can connect to it
>>> through the server. If, however, I look into the server (Versie 3.0100
>>> d11,
>>> via the internet explorer), the alias cannot be seen. When I open the
>>> configuration of the server with /interactive the alias can be seen. No
>>> refresh like F5 helps. It does show the alias when the nxServer is
>>> stoppen
>>> first, restarted and configuration is called.
>>>
>>> One time I put my machine to restart and after opening the created alias
>>> was
>>> gone completely. Which never happened with V2.

>>
>> Actually V2 was buggy. Client side created Aliases should never be stored
>> on
>> the server. The reason for that is that lots of clients create lots of
>> (temp)
>> aliases and this would lead to a real mess. That said we do have a
>> feature
>> request for adding a "Persistent" flag to the AddAlias method that will
>> allow
>> to create persistent aliases from client side.

>
>





Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Only some IDE shown in Installation? E. P. nexusdb.public.support 1 3rd June 2009 06:39 PM
NXServer lost configuration File and Alias Names Diniz \(Deltress\) nexusdb.public.support 7 25th April 2007 03:31 AM
Save Server-Configuration Otto Herdegen nexusdb.public.support 0 5th February 2007 02:54 AM
Question on NX1 and 'tmp' files created with embedded server application Rudy Poseika nexusdb.public.discussions 3 16th January 2007 06:58 PM
Restart Nexus server service Bo Nielsen nexusdb.public.support 2 14th December 2005 01:10 PM


All times are GMT +11. The time now is 08:15 AM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.