Go Back   NexusDB Newsgroups > Support Newsgroups > nexusdb.public.support
Log in
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
  #1  
Old 7th May 2012, 10:36 PM
rogisoft rogisoft is offline
Junior Member
 
Join Date: Aug 2011
Posts: 2
Default Problem with "Current NLS Version differs from NLS Version of Stored Keys"

Work with version NexusDB 3.110 in Delphi 2010 on Windows 7 (Czech localization). Here be created application and with database.
At move on computer with Windows XP also Czech localization at attempt at opening tables detects error message:

"Current NLS Version differs from NLS Version of Stored Keys. Table must be packed before index can be used"

Searched I'm how this situation solve, but solution I'm do not find. Can me somebody advise how this problem solve?
Do I need to application and with database distribute on various operating systems Windows.

Thank you yours sincerely
Igor Vodicka
  #2  
Old 7th May 2012, 11:19 PM
Ad Franse
 
Posts: n/a
Default Re: Problem with "Current NLS Version differs from NLS Version ofStored Keys"

Op 7-5-2012 12:36, rogisoft schreef:
> Work with version NexusDB 3.110 in Delphi 2010 on Windows 7 (Czech
> localization). Here be created application and with database.
> At move on computer with Windows XP also Czech localization at attempt
> at opening tables detects error message:
>
> "Current NLS Version differs from NLS Version of Stored Keys. Table must
> be packed before index can be used"
>
> Searched I'm how this situation solve, but solution I'm do not find. Can
> me somebody advise how this problem solve?
> Do I need to application and with database distribute on various
> operating systems Windows.
>
> Thank you yours sincerely
> Igor Vodicka
>
>

Pack the database
(EM, select database, right-click on tables)

Ad Franse
  #3  
Old 8th May 2012, 12:23 AM
Eivind Bakkestuen [NDD]
 
Posts: n/a
Default Re: Problem with "Current NLS Version differs from NLS Version of Stored Keys"

> Pack the database
> (EM, select database, right-click on tables)


Igor, To be more specific, you should do "Pack tables that needs NLS
update". You can look at the EM source to see how to do this for your
own application.


See also breaking changes for 3.09 for info,

http://www.nexusdb.com/support/index...exusdbbreaking

--
Eivind Bakkestuen [NDD]
  #4  
Old 8th May 2012, 12:25 AM
rogisoft rogisoft is offline
Junior Member
 
Join Date: Aug 2011
Posts: 2
Default

Quote:
Originally Posted by Ad Franse View Post
Op 7-5-2012 12:36
Pack the database
(EM, select database, right-click on tables)

Ad Franse
Does not help it, always same error.

Igor Vodicka
  #5  
Old 8th May 2012, 10:40 AM
Eivind Bakkestuen [NDD]
 
Posts: n/a
Default Re: Problem with "Current NLS Version differs from NLS Version of Stored Keys"

> Does not help it, always same error.

See the link I posted; the tables must be restructured *on the machine
they will be used on*. That's why I talked about the EM source; adding
the check to the app (or your installer, perhaps) will make sense.

--
Eivind Bakkestuen [NDD]
  #6  
Old 8th May 2012, 09:07 PM
David Rose
 
Posts: n/a
Default Re: Problem with "Current NLS Version differs from NLS Version ofStored Keys"

On 07/05/2012 23:40, Eivind Bakkestuen [NDD] wrote:
>> Does not help it, always same error.

>
> See the link I posted; the tables must be restructured *on the machine
> they will be used on*. That's why I talked about the EM source; adding
> the check to the app (or your installer, perhaps) will make sense.
>


Before reinventing the wheel, has anyone extracted this in to a
standalone exe or dll that can be called from an installer, as I assume
everyone will need this at sometime or another ?


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Packing Tables (Current NLS Version differs...) Charlie Heaps nexusdb.public.support 3 22nd November 2011 10:01 PM
Current NLS Version differs from NLS Version of Stored Keys. Tablemust packed Bernhard Roos nexusdb.public.support 40 20th October 2011 10:23 PM
Current NLS Version differs Wolfgang nexusdb.public.support 2 29th July 2011 04:05 PM
ANN: Multi DBMS tool "Database Workbench" version 2.8.7 released Martijn Tonies nexusdb.public.support.thirdparty 0 14th June 2006 08:04 PM
Import CSV: Selecting "Overwrite" in "Advanced option" gives "Abstract error" when "Finish" is pressed Jesper Ƙstergaard nexusdb.public.support 1 6th July 2003 01:10 PM


All times are GMT +11. The time now is 05:59 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.